Compatibility

Host Operating System / Environment Minimum recommended docker versions Known issues / tips
Linux - general Docker v1.10
Linux - Travis CI Docker v1.10 See example .travis.yml for baseline Travis CI configuration
Linux - Circle CI (LXC driver) Docker v1.9.1 The exec feature is not compatible with Circle CI. See example circle.yml for baseline CircleCI configuration
Linux - within a Docker container Docker v1.12 See Running inside Docker for the detailed configuration
Mac OS X - Docker Toolbox Docker Machine v0.8.0
Mac OS X - Docker for Mac 1.12.0 Support is best-efforts at present. getTestHostIpAddress() is not currently supported due to limitations in Docker for Mac.
Windows - Docker Toolbox Support is limited at present and this is not currently tested on a regular basis.
Windows - Docker for Windows Supported is limited at present (Docker Compose tests are failing) and not currently tested on a regular basis.

results matching ""

    No results matching ""